[SOLVED] AW 0.5.7 fails at launch time (Plz move that topic)

Hier können eigene Artweaver Materialien veröffentlicht und gedownloadet werden - Here you can publish custom Artweaver materials and download them.
EminoMeneko
Beiträge: 3
Registriert: So Dez 28, 2008 3:32 pm

[SOLVED] AW 0.5.7 fails at launch time (Plz move that topic)

Beitragvon EminoMeneko » So Dez 28, 2008 3:49 pm

Hello,

I found out that a new version is here and I tried to install it.
I uninstalled the previous 0.5.6 version keeping all the plugins in the folder and startup failed so I removed anything, cleaned the folder and the registry but it kept failing on startup so I tried the portable version but still the same.
Is 0.5.7 a beta version ?
Does it need some special external libraries to work fine ?

For the convenience of the developpers I copy/paste the error log here...

Code: Alles auswählen

<?xml version="1.0" encoding="UTF-16"?>
<DATABASE>
<EXE NAME="Artweaver.exe" FILTER="GRABMI_FILTER_PRIVACY">
    <MATCHING_FILE NAME="Artweaver.exe"
     SIZE="3615744"
     CHECKSUM="0x4B896CE2"     BIN_FILE_VERSION="0.5.7.459"
     BIN_PRODUCT_VERSION="0.5.7.459"     PRODUCT_VERSION="0.5.7"
     FILE_DESCRIPTION="Artweaver 0.5"     COMPANY_NAME="Artweaver"
     PRODUCT_NAME="Artweaver 0.5"     FILE_VERSION="0.5.7.459"
     ORIGINAL_FILENAME="Artweaver.exe"     INTERNAL_NAME="Artweaver"
     LEGAL_COPYRIGHT="© 2002-2008 Boris Eyrich"
     VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4"
     VERFILETYPE="0x1" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0"
     LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="0.5.7.459"
     UPTO_BIN_PRODUCT_VERSION="0.5.7.459" LINK_DATE="06/19/1992 22:22:17"
     UPTO_LINK_DATE="06/19/1992 22:22:17" VER_LANGUAGE="Allemand (Allemagne) [0x407]" />
    <MATCHING_FILE NAME="DlgMgr.dll"
     SIZE="1160704" CHECKSUM="0xB6A921B9" BIN_FILE_VERSION="0.5.7.101"
     BIN_PRODUCT_VERSION="0.5.7.101" PRODUCT_VERSION="0.5"
     FILE_DESCRIPTION="Dialog Manager" COMPANY_NAME="Artweaver"
     PRODUCT_NAME="Dialog Manager" FILE_VERSION="0.5.7.101"
     ORIGINAL_FILENAME="DlgMgr.dll" INTERNAL_NAME="DlgMgr"
     LEGAL_COPYRIGHT="© 2002-2008 Boris Eyrich" VERFILEDATEHI="0x0"
     VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x1" MODULE_TYPE="WIN32"
     PE_CHECKSUM="0x0" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="0.5.7.101"
     UPTO_BIN_PRODUCT_VERSION="0.5.7.101" LINK_DATE="06/19/1992 22:22:17"
     UPTO_LINK_DATE="06/19/1992 22:22:17" VER_LANGUAGE="Allemand (Allemagne) [0x407]" />
    <MATCHING_FILE NAME="Plugin.dll" SIZE="61440" CHECKSUM="0x86856A37"
     BIN_FILE_VERSION="0.5.0.55" BIN_PRODUCT_VERSION="0.5.0.55"
     PRODUCT_VERSION="0.5" FILE_DESCRIPTION="Plugin DLL"
     COMPANY_NAME="Artweaver" PRODUCT_NAME="Plugin DLL" FILE_VERSION="0.5.0.55"
     ORIGINAL_FILENAME="Plugin.dll" INTERNAL_NAME="PluginDLL"
     LEGAL_COPYRIGHT="© 2002-2008 Boris Eyrich" VERFILEDATEHI="0x0"
     VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x1" MODULE_TYPE="WIN32"
     PE_CHECKSUM="0x0" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="0.5.0.55"
     UPTO_BIN_PRODUCT_VERSION="0.5.0.55" LINK_DATE="06/19/1992 22:22:17"
     UPTO_LINK_DATE="06/19/1992 22:22:17" VER_LANGUAGE="Allemand (Allemagne) [0x407]" />
</EXE>
<EXE NAME="kernel32.dll" FILTER="GRABMI_FILTER_THISFILEONLY">
    <MATCHING_FILE NAME="kernel32.dll" SIZE="1054720" CHECKSUM="0x98676D5"
     BIN_FILE_VERSION="5.1.2600.5512" BIN_PRODUCT_VERSION="5.1.2600.5512"
     PRODUCT_VERSION="5.1.2600.5512"
     FILE_DESCRIPTION="DLL du client API BASE Windows NT"
     COMPANY_NAME="Microsoft Corporation"
     PRODUCT_NAME="Système d'exploitation Microsoft® Windows®"
     FILE_VERSION="5.1.2600.5512 (xpsp.080413-2111)" ORIGINAL_FILENAME="kernel32"
     INTERNAL_NAME="kernel32"
     LEGAL_COPYRIGHT="© Microsoft Corporation. Tous droits réservés."
     VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x40004"
     VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0x1049F8"
     LINKER_VERSION="0x50001" UPTO_BIN_FILE_VERSION="5.1.2600.5512"
     UPTO_BIN_PRODUCT_VERSION="5.1.2600.5512" LINK_DATE="04/14/2008 02:33:02"
     UPTO_LINK_DATE="04/14/2008 02:33:02" VER_LANGUAGE="Français (France) [0x40c]" />
</EXE>
</DATABASE>

Zuletzt geändert von EminoMeneko am Sa Jan 31, 2009 2:42 pm, insgesamt 2-mal geändert.

JPurdy
Beiträge: 1
Registriert: Mo Dez 29, 2008 3:06 am

Beitragvon JPurdy » Mo Dez 29, 2008 5:13 am

Hello,

Version 0.5.7 seemed to install fine on my machine (WindowsXP SP2) then failed upon execution:

"Artweaver.exe has encountered a problem and needs to close. We are sorry for the inconvenience.... Please tell Microsoft about this problem."

Does anyone know if the older versions are still available?

EminoMeneko
Beiträge: 3
Registriert: So Dez 28, 2008 3:32 pm

Beitragvon EminoMeneko » Mo Dez 29, 2008 2:08 pm

I don't know what happened but it seems it is not an Artveaver version Issue...
I found a 0.5.6 version and it did the same...
I wonder what is faulty... http://www.clubic.com/lancer-le-telecha ... eaver.html

I have a 0.5.5 backup and it did the same too... xD

EDIT:

Still the same even if I uninstalled everything and cleared the registry.
To try to find some information about the origin of the problem I tried to use a debugger. Here is the message I get

Code: Alles auswählen

0:000> g
(be8.638): Access violation - code c0000005 (first chance)
First chance exceptions are reported before any exception handling.
This exception may be expected and handled.
eax=017ee368 ebx=00403d83 ecx=00000000 edx=0012efcc esi=00000000 edi=0012ff3c
eip=004032fc esp=0012efc4 ebp=0012ff54 iopl=0         nv up ei pl nz na po nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00210202
Artweaver+0x32fc:
004032fc 8b08            mov     ecx,dword ptr [eax]  ds:0023:017ee368=????????


So this may be caused by a problem with pointers or undeclared variables but as I already said it can't be Artweaver program which causes that because 0.5.6 worked fine and Now none versions work so the problem is probably external but i can't find why and how it does happen... xD

EDIT 2:

Strange but after i used the debugger Artweaver started again. I wonder what happened.
Dateianhänge
strange_artweaver_revival.PNG
Artweaver has started again and this is the last 0.5.7 version...
Computers are strange sometimes... xD

Leif
Beiträge: 1
Registriert: Mi Dez 10, 2008 6:14 pm
Wohnort: Denmark

Beitragvon Leif » Mo Dez 29, 2008 7:00 pm

Artweaver 0.5.7 crashed several times for me while i was dong some Acryl brush painting. :( But i found a way to make it work.

I have set the history to 100 states. But if i frequently delete the history Artweaver didn’t crash. :?:

EminoMeneko
Beiträge: 3
Registriert: So Dez 28, 2008 3:32 pm

Beitragvon EminoMeneko » Di Dez 30, 2008 11:02 am

The problem came back so it isn't solved.
My own problem is not that it crashes after some use but it can't start up. Yesterday it has started once after I used a debugger but today it crashes again.

I hope we can have some help soon. And I sent a message to the admin because I think that topic is not in the right place, so if there are other moderators, please move that topic in the right forum.
Thank you. i just started an drawing yesterday in awd format... No one can read that until AW is repaired... :cry:

EDIT :
Absolutely lame ! :oops:
I just deleted the artweaver folder in the %USERPROFILE%\Application Data folder and it started again... xD
it seems the profile was corrupted for some obscure reason but now it seems to work fine and startup.

EDIT 2:
OK it's night and I thought it may be solved but now it crashes again. I deleted the settings in the profile but doesn't work anymore... xD
It drives me crazy.

EDIT 3:
(31/01/2009)
It seems that for an unknown reason Artweaver launches a normal way. I don't know what happened for the software to fail at launch time and now working again but i think I can consider this problem is solved. Unfortunately there is nothing precise in the case someone else meets that problem.


Zurück zu „Artweaver user materials“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste