Seite 1 von 1

Crash report: Message boxes during moving layers

Verfasst: Mi Mär 26, 2014 5:23 pm
von dwsel
While moving the layer on top of the stack the bad behaviour happened. It must have been some kind of unhandled exception, because there was no usual 'report error' box. Instead the stack of message box appeared after several seconds. It happened quite fast, I was more concerned about my screen filling up with message boxes so I went to process explorer with intention to kill the app rather than reading the message. The whole application crashed while killing the process.

After restarting the application it started to recover the session without asking a question. Also the replaying of events was unstoppable. I didn't want that because the session was quite long and I had intermediate saves. I've killed the application but after another restart the same behaviour happened - the only choices were either to delete Recovery folder from user data or to let the computer run for several minutes during the events replay.

Re: Crash report: Message boxes during moving layers

Verfasst: Do Mär 27, 2014 9:27 am
von Boris Eyrich
I will check the crash. Do you remember the text in the message boxes?

The automatic recovery of all documents after Artweaver has crashed or unexpected ended is a new feature since version 4.5 to avoid any date loss in such situations. But I see sometimes it is not wanted to recover any document thus I will add some kind of confirmation in the next major version of Artweaver.

Re: Crash report: Message boxes during moving layers

Verfasst: So Mär 30, 2014 9:52 pm
von dwsel
Boris Eyrich hat geschrieben:I will check the crash. Do you remember the text in the message boxes?

Unfortunately not. They were blinking quite fast.

Re: Crash report: Message boxes during moving layers

Verfasst: Do Apr 03, 2014 5:23 pm
von dwsel
I've managed to reproduce the bug and capture the bug. It's related to
- mouse scrolling (zooming)
- moving the layer
So far it's specific to the file I'm working on (maybe it's invisibly broken?). I'll PM you with the link to the file.

P.S. Can't seem to upgrade to 4.5.2 to see if it's accidentally fixed. Should I switch channel?

Re: Crash report: Message boxes during moving layers

Verfasst: Sa Apr 05, 2014 1:39 pm
von Boris Eyrich
I can sometimes reproduce a some similar crash while dragging layers (but without the message boxes). I will check this and try to fix it with the next update.

P.S. Can't seem to upgrade to 4.5.2 to see if it's accidentally fixed. Should I switch channel?

Update should now also work from the prerelease channel.

Re: Crash report: Message boxes during moving layers

Verfasst: So Mai 04, 2014 11:32 am
von Boris Eyrich
Should be fixed now with Artweaver 4.5.3.