Seite 1 von 1

hotkey bug

Verfasst: So Okt 18, 2009 10:06 pm
von red_produkt
<EDIT!>
ok, it looks like a full reinstall fixed my problem. I started getting suspicious when I noticed that the file format plugins were'nt being loaded, and the program config must be borked somehow. So, it looks like it's fine, although i guess it might be worth looking into how it got borked
</EDIT!>


Hi, I just purchased artweaver. I love the brush painting engine, but I have been encountering an infuriating bug

I'm using windows vista, on a fast new system. I can get the specs if you need.
maybe 80-90% of the time, if I hit ctrl-z, an action will be undone, and the current tool will change to the move tool until I click again. as you can guess, when deep in the middle of painting something this is more than a little bit annoying

I tried changing the keyboard shortcut for undo, but every shortcut I tried was invalid, even shift-z, to which artweaver said 'shortcuts must contain shift/ctrl' .... so I guess this post is actually about 2 bugs :)


it is 100% reproducible on my machine, if you hit ctrl-z fast. if you do it really slowly, no problem.. but I don't work slowly so it's really a 'shout at the computer' problem for me :)

thanks!
rich

edit: ok I thought initially it was a problem with the ctrl key, but the problem doesnt happen with other ctrl shortcuts, only undo. so it seems to be a bug with the undo function?

NOTE: this bug does not appear in artweaver free, it seems to be just in plus

Re: hotkey bug

Verfasst: Mo Okt 19, 2009 10:27 am
von Boris Eyrich
if I hit ctrl-z, an action will be undone, and the current tool will change to the move tool until I click again. as you can guess, when deep in the middle of painting something this is more than a little bit annoying

This is a bug and it is also present in the free version. I'm currently working on it and it will be fixed with one of the next updates.

Re: hotkey bug

Verfasst: Di Okt 27, 2009 2:30 pm
von Boris Eyrich
The behavior should have been improved with the latest update of Artweaver (Version 1.06).

Re: hotkey bug

Verfasst: Do Okt 29, 2009 8:16 pm
von red_produkt
thanks for the update!
checking it out..

Re: hotkey bug

Verfasst: Mo Nov 02, 2009 1:11 am
von red_produkt
Hi Boris!
I haven't run into this behaviour again, however there is one other thing I would appreciate if you had a quick look?

I notice when zooming in and out a lot, and panning about by hitting space: sometimes space does not instantly change the tool to 'hand'. This means sometimes when I'm navigating a painting, I draw a big stroke across it :)
it's less frustrating than the move tool thing, but if I don't notice the stroke and keep going without undo, it could be kind of annoying to have rogue strokes on a painting :D
maybe it adds to them ;)

Re: hotkey bug

Verfasst: Di Nov 03, 2009 10:22 pm
von Boris Eyrich
however there is one other thing I would appreciate if you had a quick look?

I will check this