Öffnen von Datei mit AW über Explorer

Hier können Fragen zu Artweaver gestellt werden.
Vock
Beiträge: 165
Registriert: Fr Jan 26, 2007 12:38 pm
Wohnort: Berlin

Öffnen von Datei mit AW über Explorer

Beitragvon Vock » Sa Sep 15, 2007 11:19 am

Habe in neuester Version folgenden Bug festgestellt: Wenn ich im Explorer eine Datei mit AW öffnen will, indem ich einfach auf diese Datei mit der entsprechenden Endung (z.B. .jpg) klicke, dann öffnet AW die Datei, diese läßt sich aber nicht bearbeiten. Überhaupt: wenn AW auf diese Weise geöffnet wird und nicht z.B. über das Startmenü dann geht keine Bearbeitung, z.B: erstelle ich eine "Neue Datei" läßt auch diese sich nicht bearbeiten.

AW nomal über Startmenü öffnen und dann die Datei laden geht einwandfrei...

Vock
Beiträge: 165
Registriert: Fr Jan 26, 2007 12:38 pm
Wohnort: Berlin

Beitragvon Vock » So Sep 30, 2007 5:02 pm

Bin mittlerweile mit dem Problem etwas weiter gekommen: Habe AW nochmals vollständig deinstalliert und auch die Registry aufgeräumt (mit CCleaner). Danach AW 0.4.8.1 nochmals neu installiert. Bei der Installation darf man nicht gleich angeben, dass AW mit bestimmten Dateitypen zum automatischen Öffnen verknüpft sein soll - genau dann tritt der Fehler auf, dass die Dateien mit Doppelklick vom Explorer aus zwar geöffnet werden, sich aber nicht mehr bearbeiten lassen.

Man kann jedoch nachträglich die automatische Zuordnung durchaus noch festlegen: z.B. vom Windows Explorer aus mit "Öffnen mit..." eine Datei mit der gewünschten Endung (z.B. .jpg, .png etc) anklicken und dann auswählen, das diese Datei immer mit AW geöffnet werden soll.


So klappt's; ist aber sicher nicht im Sinne des Erfinders.

Benutzeravatar
Boris Eyrich
Site Admin
Beiträge: 1667
Registriert: Mo Nov 01, 2004 2:59 pm
Kontaktdaten:

Beitragvon Boris Eyrich » Mo Okt 01, 2007 11:12 am

Das scheint in diesem Fall dann ein Problem mit DDE zu sein. Artweaver verwendet seit der Version 0.4.8 das DDE Protokoll von Windows um Dateien bei einem Doppelklick zu öffnen.

Bei dem hier vorgeschlagenen Workaround wird jedoch wieder die "alte" Methode eingestellt (Windows startet bei jedem Doppelklick auf eine Datei die Artweaver.exe und übergibt den Dateinamen als Parameter).

Leider kann ich momentan kein Problem in Artweaver erkennen bzw. meine Tests haben dieses Problem nicht gezeigt. Werde es trotzdem mal weiter untersuchen.

Vock
Beiträge: 165
Registriert: Fr Jan 26, 2007 12:38 pm
Wohnort: Berlin

Beitragvon Vock » Mo Okt 01, 2007 3:09 pm

Dank für die Antwort. Noch ein Hinweis: Ich habe es auf zwei verschiedenen Rechnern, einmal mit XP Home Edition und einmal mit XP Professional (für Tablet PC) ausprobiert und bei beiden Rechnern ergab sich der gleiche beschriebene Verlauf.

Vielleicht können andere User ja mal ihre Erfahrungen mitteilen?

Vock
Beiträge: 165
Registriert: Fr Jan 26, 2007 12:38 pm
Wohnort: Berlin

Beitragvon Vock » Mo Okt 01, 2007 3:28 pm

... und jetzt hat's mich noch geritten und ich habe AW 0.4.8.1 auch noch auf einem Rechner mit Vista drüberinstalliert, wo noch AW 0.4.7 drauf war - auch da das gleiche Bild; öffnen über Doppelklick geht nicht


Zurück zu „Anwenderfragen“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste